Ошибки в программе

Ошибки в программе

Сообщение sda1 » 09 июн 2016, 14:41

Код: выделить все
transmageddon.py:31: PyGIWarning: Notify was imported without specifying a version first. Use gi.require_version('Notify', '0.7') before import to ensure that the right version gets loaded.
  from gi.repository import Notify
transmageddon.py:32: PyGIWarning: GdkX11 was imported without specifying a version first. Use gi.require_version('GdkX11', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import GdkX11, Gdk, Gio, Gtk, GLib, Gst, GstPbutils, GstTag
transmageddon.py:32: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import GdkX11, Gdk, Gio, Gtk, GLib, Gst, GstPbutils, GstTag
transmageddon.py:32: PyGIWarning: Gst was imported without specifying a version first. Use gi.require_version('Gst', '1.0') before import to ensure that the right version gets loaded.
  from gi.repository import GdkX11, Gdk, Gio, Gtk, GLib, Gst, GstPbutils, GstTag
transmageddon.py:32: PyGIWarning: GstPbutils was imported without specifying a version first. Use gi.require_version('GstPbutils', '1.0') before import to ensure that the right version gets loaded.
  from gi.repository import GdkX11, Gdk, Gio, Gtk, GLib, Gst, GstPbutils, GstTag
transmageddon.py:33: PyGIWarning: GUdev was imported without specifying a version first. Use gi.require_version('GUdev', '1.0') before import to ensure that the right version gets loaded.
  from gi.repository import GUdev



Вот такие ошибки вылезают и потом глючит прога :| :geek:
sda1
Разговорчивый гость
Разговорчивый гость
 
Автор темы
Сообщений: 37
Стаж: 2 года 1 месяц 13 дней
Благодарил (а): 23 раз.
Поблагодарили: 0 раз.

Ошибки в программе

Спонсор

Спонсор
 

Re: Ошибки в программе

Сообщение Olej » 09 июн 2016, 15:14

sda1 писал(а):

Вот такие ошибки вылезают и потом глючит прога :| :geek:

Какую "прогу"? Как "глючит"?
Цитата:
Сынок! Спили мушку...

Сынок, тебе ещё собирать или писать "проги" - ещё не скоро. :twisted:
Olej
 
Стаж: 48 лет 6 месяцев 19 дней

Re: Ошибки в программе

Сообщение sda1 » 07 июл 2016, 00:43

Olej писал(а):

sda1 писал(а):

Вот такие ошибки вылезают и потом глючит прога :| :geek:

Какую "прогу"? Как "глючит"?
Цитата:
Сынок! Спили мушку...

Сынок, тебе ещё собирать или писать "проги" - ещё не скоро. :twisted:

Нет всё не так как кажется.Моё увлечение сейчас linux и то что я не мог делать пару недель назад назад сейчас с лёгкостью мне даётся.Всякое протоколирование логов, установка драйверов видеокарты и много много изучений мэнов с переводом :twisted: :twisted:
sda1
Разговорчивый гость
Разговорчивый гость
 
Автор темы
Сообщений: 37
Стаж: 2 года 1 месяц 13 дней
Благодарил (а): 23 раз.
Поблагодарили: 0 раз.

Re: Ошибки в программе

Сообщение Шпак Дмитрий » 07 июл 2016, 01:06

Вроде ругается не на те версии библиотек.
Шпак Дмитрий
Местный говорун
Местный говорун
 
Сообщений: 589
Стаж: 3 года 6 месяцев
Откуда: Russian_federation, какой то
Благодарил (а): 20 раз.
Поблагодарили: 145 раз.

Re: Ошибки в программе

Сообщение Oleg65 » 07 июл 2016, 05:21

Шпак Дмитрий писал(а):

Вроде ругается не на те версии библиотек.
Угу, и даже говорит где взять нужное, вроде
Код: выделить все
from gi.repository import Notify
:)
Аватар пользователя
Oleg65
Местный говорун
Местный говорун
 
Сообщений: 851
Стаж: 3 года 6 месяцев 2 дня
Откуда: г.Коломна Моск.обл.
Благодарил (а): 71 раз.
Поблагодарили: 205 раз.


Вернуться в Программы в Linux

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

cron